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Forum:
http://www.cellvisualization.org

Direct link to this forum entry:
http://www.cellmicrocosmos.org/Cmforum/viewtopic.php?f=21&t=737

Actual Version of CELLmicrocosmos 2.2 MembraneEditor:
http://Cm2.CELLmicrocosmos.org

Actual Version of Blender:
http://www.blender.org

Here, Blender 2.67b is used.

Blender with ePMV:
http://epmv.scripps.edu/download-install-free/installers
(Please choose version Blender 2.62)

Target

This tutorial describes cell modeling at the molecular level. It shows, how to work with:

• the MembraneEditor and how to generate simple membranes with this tool, 

• Atomic Blender and how to import atomic structures from the MembraneEditor to Blender,

• and ePMV and how to work with atomic and volumetric data structures,

• and how to distribute a number of smaller objects on the surface of a large object.

Abbreviation

RMB Right Mouse Button

LMB Left Mouse Button

http://www.cellvisualization.org/
http://epmv.scripps.edu/download-install-free/installers
http://www.blender.org/
http://Cm2.CELLmicrocosmos.org/
http://www.cellmicrocosmos.org/Cmforum/viewtopic.php?f=21&t=737


MembraneEditor

First make sure that you have installed the latest version of Java on your PC. 

http://java.com

If you are using a 64 bit PC, make sure that you are also installing the 64 bit version of Java 
providing a much better performance than Java 32 bit! If you are using a Linux system, also the 
Open Java projects should work with the MembraneEditor, so you do not need the original 
Sun/Oracle Java.

Then, download and start the MembraneEditor from this website:

http://Cm2.CELLmicrocosmos.org

After the program is started you should see something like this:

Click now on the following button “Lipids”:

http://Cm2.CELLmicrocosmos.org/
http://java.com/


Here, the library with lipids is shown. Just press on the two buttons indicated by the arrows and add 
the lipids CDNe (Cardiolipin lipid) and CLRe (Cholesterol lipid) by selecting EC/IC (which means 
extracellular and intracellular side).

Before we continue, let us decrease the size of the membrane. At the moment, it is 200 x 
200Ångström. So let us change it to  100 x 100Ångström. For this purpose, select this button:

and change the size to 100 x100 in the following dialog and press “Accept”.

Before we start to generate the membrane, let us change the lipid distribution of the 
MembraneEditor to 90% CDNe to 10% CLRe:

Now, let us generate the membrane by starting a Lipid Packing Algorithm. Click the big red button:

Select the algorithm called “Advanced Random Placing”:



The following dialog appears. You may want to play around with the values. But you can also just 
click “OK” to start the algorithm.

The result will be something like this:



Just a remark: if you are not satisfied with the result, you can just remove all lipids by clicking:

and then restart the algorithm.

Now we have the lipids, just let us add a small protein. This time, select “Proteins” in the Local 
Database:

Choose the protein 1A11_OPM and place it into the membrane. You can just click on the OPM 
symbol, the protein is placed somewhere in the Membrane View, or you keep the button pressed on 
the OPM symbol until the Drag'n'Drop symbol appears and then you place it into the membrane.

Now, the protein is placed into the membrane:

 



If you perform a RM onto the protein in the Membrane View and select “Align Molecule”, the 
following window appears:

Here, you see the atomic structures of the PDB files which are hidden in the regular view of the 
MembraneEditor. Make sure the OPM layers, indicated by a red layer on the top and a blue layer on
the bottom, are placed like shown in the screen shot. If this is not the case, press the “OPM 
Alignment” button. Then click “okay”.

To remove now the intersections between the protein and the lipids, press this button:



Our membrane system is finished. Now, we need to export it to PDB. By clicking this symbol:

The following window appears:

Here, you can change a number of output settings for the PDB file which will be generated. If you 
want to use in the future different programs to import the PDB format, keep in mind that you can 
change here a lot of settings to change the compatibility. 

The MembraneEditor comes with a very good documentation, just press “F1” to show it or press the
button  to go directly to the page discussing the current topic.

Now, two buttons are important. To preview the membrane in Jmol, just click this button

To export the PDB file, click this button. Do it, we will use this file in the next chapter.



Atomic Blender: The Standard PDB Importer for Blender

Now, we want to import the PDB file into Blender. For this purpose, Blender comes with a special 
plug-in which has to be activated.

Activate it here:

Atomic Blender

Select now File → Import → Protein Data Bank (.pdb)

Okay, guess now which PDB file you will import? Yes, take the one from the MembraneEditor.

In addition, in the appearing window you will see a lot of options, but use the basic options now:



You will see now that Blender will need some time to import this structure. So if you generated the 
100 x 100 membrane, it is a good idea to do it on a fast computer, such as an i7 with 8 GB Ram. If 
you find out that your computer is not fast enough, just generate a smaller membrane, let us say 50 
x 50. This should solve the problem.

Directly after importing the structure it is a good idea to scale the membrane done to a size fitting to
your environment. Just press “S” and scale it down.

In the Outliner, you see the different parts of the molecule. It might be a good idea to group them, 
so that it is no problem to select the whole molecule with one click. Select all segments part of the 
membrane by holding shift and LM all segment parts:



Then select Object → Group → Create New Group

If you select now “Groups” in the Outliner:



You can select the whole membrane with one click.

Because the visualization of this many spheres needs a lot of performance, it would be a good idea 
to switch to Bounding Box mode.

It will look like this and the navigation will be much faster.

Now, do the rendering by pressing F12.

In the previous tutorials you have learnt a lot of ways to improve the visualization, do it, if you want
to make a good visualization.



ePMV

Preparations

If not already done, download the ePMV-Blender version stated above and start it.

http://epmv.scripps.edu/download-install-free/installers

Choose for Windows: 

64bit- uPy-aP-eP_blender2.62_win64_1_0_app.zip
32bit- uPy-aP-eP_blender2.62_win32_1_0_app.zip

! Note that on some systems ePMV runs a little bit buggy. Please remember, all software here is free
and Open Source! With the version stated above I am working on my notebook.

Now the ePMV-Plugin has to be activated. Do this in

File → User Preferences → Addons:
• ePMV

Activate the check boxes. 

Now you are ready to use ePMV.

http://epmv.scripps.edu/download-install-free/installers


ePMV

Press the ePMV-Button  at the end of the Menu row on the top.

The ePMV menu is shown:



Load and edit a PDB file from the PDB database

1. Just use this dialog to load a file:

2. First, load the standard file: 1crn by clicking on “Fetch” (you will need an Internet 
connection for it, because it is directly downloaded from the PDB databse)

3. Now you can test a lot of options shown in

1. Preset Presentations

1. Balls+Sticks

2. Backbone Presentations

3. Surface Presentations (here you can also select Metaballs)

4. Color by

4. Note: 
Not all configurations work with every molecule, but sometimes you just have to wait for a 
longer time until all atoms are loaded

Load and edit a PDB file from the local file system

1. Now we want to load the PDB file generated with the MembraneEditor. But first, we have to
do a trick, because ePMV does not like regular names, it want a PDB 4-digit code. So, copy 
the PDB file generated with the MembraneEditor and rename it to something like 
“MT12.pdb”. 

2. 1st hint: An important hint: if you have previously loaded another PDB into ePMV, it is a 
good idea to restart Blender. In my experience, it is not sufficient to just open an empty new 
Blender environment, just restart Blender.

3. 2nd hint: Atomic Blender needs a lot of resources, ePMV needs more, because it can create 
more complex visualizations. I use for my example a 50 x 50 membrane. If you visualize 
larger structures, it might need some time!

4. Use the dialog above, select “File” and “Open PDB” or you can choose a file locally by 
pressing the “Browse” button and select the MembraneEditor PDB file, you should see 
something like this:



5. Select now as “Preset Representation” the option “RibbonProtein+CPKLigand”

6. Now, go to the camera mode by selecting NUM+0. To change now the distance to the 
membrane, just change the Z value:

The camera is attached to the membrane, therefore, Z changes the distance to the memrbane.

7. Now, press F12 to render the view, here from the side:



And here from the side (just select the molecule objects,  in my case MT12 and 
MT12_b_cpk and rotate them):

Load and edit a volumetric file

This tutorial is based on:

http://epmv.scripps.edu/documentation/tutorials/written-tutorials/general-epmv-tutorials

In this case we'll load a 3D density map of a Nuclear Pore Complex (NPC) derived from single-particle Electron 

Microscopy 

1. Visit the Electron Microscopy Data Base 
2. Click Basic Search 
3. Type nuclear into the Title box on the search page and hit the [start search] button 
4. Click on entry 1097 
5. Click Map Information 
6. Click to download then unzip emd_1097.map.gz 
7. CHANGE emd_1097.map to emd_1097.ccp4 (bug in PMV doesn't recognize the .map tag) 
8. Open ePMV 
9. Unfold DataPLayer 

http://www.ebi.ac.uk/pdbe-srv/emsearch/
http://epmv.scripps.edu/documentation/tutorials/written-tutorials/general-epmv-tutorials


10.In Data Player panel, Browse to your .ccp4 file to load it 
11.Since the EMDB file should be formatted with proper headers, the map should load at a 

correct scale compared to any molecules in the scene (often shockingly large)
1. Its wise to confirm this scale simply by making a scale bar with a cube that is the 

length of your EMDB molecule (find dimensions of that molecule with a web search 
or by asking your content expert)

12.Zoom out to see your nuclear pore complex surface map.
13.You will see now that it is a problem in Blender to show the whole molecule. 

1. Click the Molecule (emd_1097.ccp4), e.g. in the Outliner
2. Go to Properties → Object

3. Change the scaling of the object from 1 to 0.1
4. There is a problem with the origin of the object. Therefore, it should be centered by 

using the following options:
5. Go to the Object Tools (usually at the left top)
6. Click “Origin to Geometry”
7. Now the origin of the molecule has moved into its center and we can align it to the 

center of the universe

8. Now make sure in the previously used Object Rollout that the object is centered at 
Position (0,0,0) 

9. From the top view (Num+7) you should see something like this now:



10.First, make a rendering (F12). You should see, that the camera position has to be 
changed and that the light is to dim

11.First, change the camera position using the methods you learned in Tutorial 1
12.Move the camera for example by using the Object Rollout of the Properties

13.The camera should be positioned to enable the top view of the complete object, e.g. 
at Z=300.00

14.Now the problem will emerge that the object is not shown at all or only a small part 
of the object



15.Therefore, go to the Object Data menu of the Propterties
16.Search there for Lens → Clipping → End
17.Change this setting to 1000

18.Now, the complete object should be shown
19.But if we make a rendering, everything will be dark or dim
20.Now, change the light or create a new one, e.g. a point light
21.Go to Properties → Object Data and change the light intensity to 200

22.change the position of the point light to e.g. (0,0,150)
23.another option is to create a spot at the same position, here the properties are shown

(make sure to increase also here the energy and to switch of the shadows to “No 
Shadow”)



24.Create a second camera and look for an interesting position (do not forget to change 
the clipping plane as shown before)

25.Keep this camera selected
26.In the 3D View menu bar, go to Cameras → Set Active Object as Camera 

(Ctrl+NUM+0): now the selected camera is rendered and shown each time the user 
presses NUM+0



14.You can play around now with this nuclear core complex



Distribute an Object on the Surface of another Object

1. First the Object created in the last tutorial has to be simplified, because it has a quite 
complex mesh

2. Expand the Object “emd_1097.ccp4” in the Outliner and select the mesh object 
“grid_1IsoSurface”

3. Go to the Properties → Object Modifiers and add the Modifier “Remesh” and enter an 
Octree Depth of 5

4. the mesh should look like this now:

5. It may be better to choose the Mode “Smooth” in the Remesh Rollout



6. You may want to make a copy now by pressing SHIFT+D before making further changes 

7. Hide this object afterwards, for rendering as well as for the viewport

8. Now we re-select our original object, and press “Apply” in the Remesh modifier panel

9. Now the mesh of the object is simplified; this is the object – the Nuclear Pore – we want to 
distribute on a Sphere, symbolizing the Nucleus

10. Now we create an Mesh → Icosphere, this is the object, on which surface the Nuclear Pore 
will be distributed

11. Scale this Icosphere to be something like 10 times the size of the pore and use a camera to 
show the whole scene – the pore should be placed in the neighborhood of the Icosphere

12. Now we need a modifier to distribute the Pore on the Icospheres surface

1. Select the Icosphere

2. In the Properties go to the Particles dialog



3. Add a new Particle System by pressing “+”

4. The Particle System is quite complex, therefore we have to change some settings, before 
the final solution is found

5. Select in the Category “Emission”

1. Number: 20; this will be the number of distributed object shown on the surface of the
sphere

2. Select under “Emit From”: “Verts”

3. Deselect the check box “Random”

6. Select in the Category “Physics”

1. “None”, deactivating Physics – we do not need this here

7. Select in the Category “Render”

1. Parent: Icosphere; yes, this is the distribution object, the Nucleus

2. Select the Option “Object”

3. And now select as Dupli Object your Nuclear Pore, something like grid_1isoSurface

4. You do not see anything? Yes, you have to activate the check box “Unborn” (because
we do not use any real physics-driven system I guess)

5. Now, you should see 20 Pores distributed on the surface – but those are quite 
strange: instead pointing towards the inner of the Nucleus, they seem to point 
somewhere else; we have to correct this

13. We originally selected the parent object for the pore; therefore we have to correct the 
rotation of this object now

1. Select the original object; we can not fix this problem by just changing the rotation in 
Object Mode, because this transformations are not applied to the pore

2. Change to Edit Mode

3. Make sure, before selecting the object, that also the backface is taken into account 

during the selection, by selecting  

4. As you used to do in Tutorial 1, use CTRL and the left mouse button to select the whole 
object – make sure everything is selected by rotating the view around the object

5. Now select the Rotate Mode and change the rotation until the pores on the surface are 
correctly positioned



6. The major work is done, so let us put some new maps on the surface of the nucleus as 
well as the pores – remember, dark blue might be a good option and you can also add 
multiple textures, e.g. you can combine the texture “Noise” with “Musgrave”

7. But the surface of the Icosphere does not look really organic, so let us add a new 
Modifier: “Subsurf”, using 3 subdivisions for the surface

8. But now we will have to face a small problem: the Icosphere shrinked, so the pores are 
flying!

9. Let us solve this problem by returning selecting the original pore, changing again to edit 
mode by pressing TAB and this time translating the pore along its Y position until the 
distributed pores a moving into the nucleus

10. Finally, let us add the “Wave” modifier to the Nucleus and play around with it:



11. Because we modeled a nucleus, let us finish by adding the secondary nucleus wall:
1. just select the nucleus
2. be sure you are in Object Mode
3. Press SHIFT+D
4. place the duplicate in the middle
5. go to its modifiers and hide the Particle System completely, because for the inner 

layer we do not need again the pores: 
6. change the scale of the inner membrane only a small bit, so that you can see the 

difference when rendering it
12. We are done!
13. Another option is – not discussed here – is the distribution of objects along a path:

http://blendersushi.blogspot.de/2011/08/grease-scatter-objects-alternative-way.html

http://blendersushi.blogspot.de/2011/08/grease-scatter-objects-alternative-way.html

	Blender Molecular Visualization Tutorial VI
	Target
	Abbreviation
	MembraneEditor
	First make sure that you have installed the latest version of Java on your PC.
	http://java.com
	If you are using a 64 bit PC, make sure that you are also installing the 64 bit version of Java providing a much better performance than Java 32 bit! If you are using a Linux system, also the Open Java projects should work with the MembraneEditor, so you do not need the original Sun/Oracle Java.
	Then, download and start the MembraneEditor from this website:
	http://Cm2.CELLmicrocosmos.org
	After the program is started you should see something like this:
	Click now on the following button “Lipids”:
	Here, the library with lipids is shown. Just press on the two buttons indicated by the arrows and add the lipids CDNe (Cardiolipin lipid) and CLRe (Cholesterol lipid) by selecting EC/IC (which means extracellular and intracellular side).
	Before we continue, let us decrease the size of the membrane. At the moment, it is 200 x 200Ångström. So let us change it to 100 x 100Ångström. For this purpose, select this button:
	and change the size to 100 x100 in the following dialog and press “Accept”.
	Before we start to generate the membrane, let us change the lipid distribution of the MembraneEditor to 90% CDNe to 10% CLRe:
	Now, let us generate the membrane by starting a Lipid Packing Algorithm. Click the big red button:
	Select the algorithm called “Advanced Random Placing”:
	The following dialog appears. You may want to play around with the values. But you can also just click “OK” to start the algorithm.
	The result will be something like this:
	Just a remark: if you are not satisfied with the result, you can just remove all lipids by clicking:
	and then restart the algorithm.
	Now we have the lipids, just let us add a small protein. This time, select “Proteins” in the Local Database:
	Choose the protein 1A11_OPM and place it into the membrane. You can just click on the OPM symbol, the protein is placed somewhere in the Membrane View, or you keep the button pressed on the OPM symbol until the Drag'n'Drop symbol appears and then you place it into the membrane.
	Now, the protein is placed into the membrane:
	
	If you perform a RM onto the protein in the Membrane View and select “Align Molecule”, the following window appears:
	Here, you see the atomic structures of the PDB files which are hidden in the regular view of the MembraneEditor. Make sure the OPM layers, indicated by a red layer on the top and a blue layer on the bottom, are placed like shown in the screen shot. If this is not the case, press the “OPM Alignment” button. Then click “okay”.
	To remove now the intersections between the protein and the lipids, press this button:
	Our membrane system is finished. Now, we need to export it to PDB. By clicking this symbol:
	The following window appears:
	Atomic Blender: The Standard PDB Importer for Blender
	In the previous tutorials you have learnt a lot of ways to improve the visualization, do it, if you want to make a good visualization.
	ePMV
	Preparations
	ePMV
	Load and edit a PDB file from the PDB database
	1. Just use this dialog to load a file:
	2. First, load the standard file: 1crn by clicking on “Fetch” (you will need an Internet connection for it, because it is directly downloaded from the PDB databse)
	3. Now you can test a lot of options shown in
	1. Preset Presentations
	1. Balls+Sticks
	2. Backbone Presentations
	3. Surface Presentations (here you can also select Metaballs)
	4. Color by
	4. Note: Not all configurations work with every molecule, but sometimes you just have to wait for a longer time until all atoms are loaded
	Load and edit a PDB file from the local file system
	1. Now we want to load the PDB file generated with the MembraneEditor. But first, we have to do a trick, because ePMV does not like regular names, it want a PDB 4-digit code. So, copy the PDB file generated with the MembraneEditor and rename it to something like “MT12.pdb”.
	2. 1st hint: An important hint: if you have previously loaded another PDB into ePMV, it is a good idea to restart Blender. In my experience, it is not sufficient to just open an empty new Blender environment, just restart Blender.
	3. 2nd hint: Atomic Blender needs a lot of resources, ePMV needs more, because it can create more complex visualizations. I use for my example a 50 x 50 membrane. If you visualize larger structures, it might need some time!
	4. Use the dialog above, select “File” and “Open PDB” or you can choose a file locally by pressing the “Browse” button and select the MembraneEditor PDB file, you should see something like this:
	5. Select now as “Preset Representation” the option “RibbonProtein+CPKLigand”
	6. Now, go to the camera mode by selecting NUM+0. To change now the distance to the membrane, just change the Z value:
	The camera is attached to the membrane, therefore, Z changes the distance to the memrbane.
	7. Now, press F12 to render the view, here from the side:
	And here from the side (just select the molecule objects, in my case MT12 and MT12_b_cpk and rotate them):
	Load and edit a volumetric file
	Distribute an Object on the Surface of another Object




