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Direct link to this forum entry:
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Actual Version of Blender:
http://www.blender.org

Here, Blender 2.7a is used.

Part I: Blender Introduction

Target

This tutorial describes the basic functionality of Blender. It is important to go through the whole 
tutorial, because these basic knowledge will be important in the future and most of it will not be 
repeated!

What is Blender?

Wikipedia

Blender was developed as an in-house application by the Dutch animation studio Neo Geo and Not 
a Number Technologies (NaN). It was primarily authored by Ton Roosendaal, who had previously 
written a ray tracer called Traces for Amiga in 1989. The name "Blender" was inspired by a song by
Yello, from the album Baby.

Roosendaal founded NaN in June 1998 to further develop and distribute the program. The program 
was initially distributed as shareware until NaN went bankrupt in 2002.

The creditors agreed to release Blender under the terms of the GNU General Public License, for a 
one-time payment of €100,000 (US$100,670 at the time). On July 18, 2002, a Blender funding 
campaign was started by Roosendaal in order to collect donations and on September 7, 2002 it was 
announced that enough funds had been collected and that the Blender source code would be 
released. Today, Blender is free, open-source software and is, apart from the two half-time 
employees and the two full-time employees of the Blender Institute, developed by the community.

The Blender Foundation initially reserved the right to use dual licensing, so that, in addition to 
GNU GPL, Blender would have been available also under the "Blender License", which did not 
require disclosing source code but required payments to the Blender Foundation. However, this 
option was never exercised and was suspended indefinitely in 2005.[5] Currently, Blender is solely 
available under GNU GPL.

There are many videos available in the Internet which were created with Blender. Just search for 
them!

http://www.cellmicrocosmos.org/Cmforum/viewtopic.php?f=21&t=753
http://www.blender.org/


Installation

We will be working with Blender version 2.67b, because it is quite stable. Go to the Blender 
website, locate the older versions, and download the version for your OS.

Preparations

Menu → File → User Preferences

→ Addons:

activate: 
Import-Export: Import Images as Planes

→ Input

activate “Emulate 3 Button Mouse” for using Blender with a Mobile PC

In addition, activate the “Fly Mode” in the “Input” section and then press: “Save As Default/Save 
User Settings” to make sure, next time you start Blender, you do not have to redo these settings 
again:



Shortcurt keys

Now, a number of shortcuts will follow. Of course it is a good idea to remember most of the 
shortcuts in the future on your own, because working with Blender is much faster with shortcuts 
instead of using the menus. However, to support you during your work, KatsBits provides a very 
nice keyboard chart which you can download here for free:

http://www.katsbits.com/tutorials/blender/useful-keyboard-shortcuts.php

Object Mode

Create an Object

First, if in the center of the
blender workspace there is no
cube, create a new one, by
selecting the tab “Create” and
clicking on “Cube”.

 

http://www.katsbits.com/tutorials/blender/useful-keyboard-shortcuts.php


Orientation

Pay attention to the X/Y/Z axis at the left bottom corner of the view port: 
X is red, Y is green, Z is blue:

! The following keyboard and mouse short cuts apply only to the view port. Therefore, the mouse ! 
! cursor must be always inside the view port. All short cuts depend on the actually active window !

Viewport Movement

Mouse-Movement
+ Center-Click  or Alt+Left-Click: emulate Center Mouse Button & Rotate 
+ Center-Click+Shift or Alt+Shift+Left-Click: move horizontally/vertically
+ Center-Click+Ctrl or Ctrl+Shift+Left-Click: zoom in/out or Mouse-Wheel

Mouse-Wheel
+Shift: movement along the camera's Y-axis
+Ctrl: movement along the camera's X-axis
+Ctrl+Shift: rotation along the camera's Z-axis

Selections

A : Select or Deselct All
Right-Click : Select 
Left-Click : Set Position of the Cursor
Ctrl+Left-Click : Draw Shape and Select
B and then select by pressed Left-Click: Border Select 
C and then select by pressed Left-Click: Pencil Select 
ESC : Abort selection etc. or Back to 3D View (if e.g. in Render Mode)

Num-Pad and Viewports

1 : Front
3 : Side
7 : Top
CTRL+# : Opposite (e.g. CTRL+1: Rear)
5 : Orthographic/Perspective View
4,2,6,8 : Rotate in 45° steps
0 : Switch Camera View/Perspective View 
Shift+F : Free Floating Mode for Camera/Perspective View, finish with left click
+/– : Zoom in/out
Pos1 : Show all objects
Shift-C : The view is shifted to show all objects



Manipulation Modes

In combination with the Left-Mouse-Button:
G : Grap
R : Rotate
S : Scale
G/R/S+Axis : Translation/Rotation/Scale along the chosen Axis (X,Y,Z)
G/R/S+Alt : Undo last transformation (“Object Mode”; not in “Edit Mode”)
Esc or Right-Mouse-Button: Abort the last action
Ctrl+Space : Show/Hide Manipulators

Select here the manipulator needed  (in this case the arrow):

Left-Click on Arrows of Object : Movement along the chosen axis
Ctrl+Movement : in full Blender steps
Ctrl+Shift : Movement in 1/10 Blender steps
Ctrl-Z : Undo (32 Undos, can be changed File → Preferences → 

  „Editing“ → Change Size of UnDo History)
Ctrl-Shift-Z : Redos
The Last Action/Transformation is shown here and can be manipulated:



Set Origin: change the Gizmo of an object

Edit Mode

Tab: Edit Mode (toggle between Object and Edit Mode)

select with Right Mouse Button single vertices

Shift: Multiple Selection, keep pressed by selecting 4 nodes

S + 0 + Enter → Place all selected nodes in one place 
(S for scale, 0 Scales the distances between all selected nodes to 0; 
 pressing S + 10 would scale the distances between all selected nodes to the 10th of their length;
 this method can again be combined with X, Y and Z restraints, e.g. by selecting S + X + 0;
 watch the actual scale on the left bottom corner shown below)

W → “Specials” Pup-Up for Edit Mode appears, select:
– Remove Doubles: Removes all overlapping vertices in one position, e.g. after using S+0



Further Shortcuts:

X : Delete Objects
Shift+A : Add Objects to actual object (remember, we are in Edit Mode, these objects will be 

  not single object, but they will be added to the actually edited object)
Ctrl + Tab : Change Sub-Edit Mode: Vertex, Edge, or Face

F : Combine selected vertices to 
a) lines if 2 vertices are selected, or 
b) to faces if more than 2 vertices are selected

E : Extrude selected vertex/vertices, lines of faces
Alt+M : Merge selected nodes (Edit Mode only)
W → Specials: Subdivide line between selected vertices

API-Navigator

Help → Python API Reference

The Python-Scripts executed by Blender are always shown in the top section which is normally 
hidden. To open this section, the yellow marked line (see screen shot) has to be dragged down with 
the Mouse+LeftPress.
 



Properties Window

N → Properties of the selected object



Background Image

This image is only shown in view ports, e.g. in the camera perspectives:

(this is still the properties dialog)

This maybe useful if an image should be used as a base for a three-dimensional object, e.g. image 
segmentation. Important: If “All Views” is chosen, the images are only shown in orthographic 
perspective, which is toggled by “5” on the NumPad

→ Therefore, usually it will be needed to correlate an image with a plane:

A Plane with an Image

The complex way

(Attention only for those who plaid around with the render settings: use the standard renderer: the 
Blender Renderer)

Create the Plane:

Make sure, that “Textured Solid” is checked in the properties (Press N to toggle properties):



Create a new Material (the plane has to be selected):



Create a new Texture:        →      →



The easy way



World Background Settings

Change the Light/Background Settings in the World Options:

Hide and Select Options

H → Hide all selected

Shift+H → Hide all unselected

Alt+H → Unhide all

A → De-Select All

Shift+D → Duplicate

E → Extrude selected nodes or shapes

F → create face between selected vertexes

Modifiers

Generate/Mirror Modifier

Generate/Subdivision Surface



Part II: CELLmicrocosmos PathwayIntegration Introduction
Björn Sommer, Bielefeld University,
Version 19.08.2014

Forum:
http://www.cellvisualization.org

Direct link to this forum entry:
http://www.cellmicrocosmos.org/Cmforum/viewtopic.php?f=21&t=750

Actual Version of Blender:
http://www.blender.org

Here, Blender 2.7a is used.

CELLmicrocosmos 1.1 CellExplorer/4.2 PathwayIntegration
http://cm4.cellmicrocosmos.org

Target

This tutorial describes how to work with the CellExplorer, how to generate a simplified 
mitochondrion model with Blender, how to import this model into the CellExploer, how to correlate
it with a pathway, how to export this model and import it into Blender.

Abbreviation

RMB Right Mouse Button

LMB Left Mouse Button

http://cm4.cellmicrocosmos.org/
http://www.blender.org/
http://www.cellmicrocosmos.org/Cmforum/viewtopic.php?f=21&t=750
http://www.cellvisualization.org/


CellExplorer: Open a Cell Model

First make sure that you have installed the latest version of Java on your PC. 

http://java.com

If you are using a 64 bit PC, make sure that you are also installing the 64 bit version of Java 
providing a much better performance than Java 32 bit! If you are using a Linux system, also the 
Open Java projects should work with the MembraneEditor, so you do not need the original 
Sun/Oracle Java.

Then, download and start the CellExplorer (incl. PathwayIntegration) from this website:

http://Cm4.CELLmicrocosmos.org/

After the program is started you should see something like this:

Click on the first file on the left side and the animal cell is loaded.

To get now information according the navigation etc., just click on the window for which you want 
to get more information. E.g., click on the Title “CellUniverse” at this 

http://Cm4.CELLmicrocosmos.org/
http://java.com/


and have a look to the Guide showing all information about how to navigate through the 
CellUniverse.

All 3D shapes are based on single VRML97 files. VRML97 was finalized in 1997 and is also 
known as VRML 2.0 (in contrast to the older version VRML 1.0). It is a text-based format which 
defines three-dimensional objects. This file format contains color information, vertices and the 
definition of the edges between these vertices, transparency information, lighting, normals, etc. The 
VRML97 definition can be found here:

http://www.web3d.org/x3d/specifications/vrml/

Now, we want to combine this simple cell model with a pathway. First, you have to download the 
following files from the forum:

http://www.cellmicrocosmos.org/Cmforum/viewtopic.php?f=21&t=737

• Blender_Tutorial_SS2014__2_0files.zip
• It contains the folder:

• io_scene_x3d/
• For VRML2 import: Place this folder into the following Blender directory (and 

substitute the original folder with the same name):
• C:\Program Files\Blender Foundation\Blender\2.67\scripts

• And the file:
• vrml_export_266.py

• For VRML2 export.
• and the Cm4 file:

hsa00562_29042014_ANDCell2014.Cm4

Unzip “hsa00562_29042014_ANDCell2014.Cm4” and click in the CellExplorer on the button

, deselect the “Cm4 option”, as shown on the next image, and open the file 
“hsa00562_29042014_ANDCell2014.Cm4”:

and then open the file “hsa00562_29042014_ANDCell2014.Cm4”. The file is loaded and now just 
click on the “Start Visualization” button:

http://www.cellmicrocosmos.org/Cmforum/viewtopic.php?f=21&t=737
http://www.web3d.org/x3d/specifications/vrml/


The cell model is now combined with pathway. 

The pathway hsa00562 is the “Inositol phosphate meabolism”. It was previously downloaded from 
our KEGG database integration in the DAWIS-M.D. data warehouse system and then localized by 
using a set of databases.  “hsa” is the abbreviations for homo sapiens, and 00562 is the KEGG-
internal number of the pathwa^y.

At the moment, all protein localizations are assigned to different localizations the way they were 
directly downloaded from the database. To change this, click 1. onto the option button labeled with 
“No Statistics” and activate the statistics by activating “Localizations”, and then 2. double click 
onto the actual pathway 00562.



Then, 1. double-click on the pink chart representing the cytosol, then 2. double-click again onto the 
pathway 00562 and 3. onto the red chart representing the cell. 

What did you do? First you have assigned all proteins providing localization information pointing to
the cytosol to the cell component cytosol (2nd priority) and then you have assigned all proteins 
providing localization information pointing towards the cell membrane to the cell component with 
the same name (1st priority).

Now, to actualize the 3D visualization, you only have to click again onto “Update Visualization”. 
The 3D visualization shows now potential protein localizations based on database-acquired data.

One more hint: if only the layout of a 3D pathway should be analyzed, it might make sense to 
assign all protein localizations to a single cell component. You can use the previously described 
procedure for this purpose, but you need to activate the “unknown” check box. Otherwise, those 
localizations which are not based on a database entry will not be activated:



In this way, it is for example to force the program to map all proteins onto a single specific cell 
component.

Now, let us choose another node placing algorithm. Open the corresponding dialog by selecting in 
the menu “Settings” → “Edit Algorithm Settings”. And then, select the algorithm 
“SphereMappingLayout” and close the window again:

Click again “Update Visualization” and you will see that the layout changes.

If you want to compare the original layout with the 3D visualization, click and drag the 2DViewer 
to the right side of the window and then activate the CellUniverse again. You will see now that the 
SphereMappingLayout places the nodes onto the surface of the cell component by utilizing the 2D 



coordinates. By the way, in this case, all protein localizations were previously exclusively assigned 
to the cell membrane.

Blender: From Plane to Cell Component

First, delete all 3D objects from the scene with select and DEL (not the camera and the light!)

Then, create a plane:

It should be placed in the center of the 3D view

If it is not, you may use the Transform Window (it appears when pressing N) to change the Location
to 0,0,0.

Now, make sure the plane is selected and change to Edit mode by pressing TAB.

The, start to extrude the plane to a 3D object by pressing E and moving the mouse pointer upward 
while pressing CTRL. While doing so, move the newly generated side to the first possible position 
and click LM.



Now, just repeat this process 5 times:

Okay, this does not really look like a cell component, but we will change this now. Leave the Edit 
Mode by pressing TAB again, and now, we will add a modifier. 

Make sure, the object is still selected, go to the modifier section in the properties section and add 
the modifier “Subdivision Surface” (sub section “Generate”):



Then, change the “Subdivisions” in view to value 3, and this happens now:

A good starting point fo a mitochondrion, or what do you think?

This is our initial 3D shape. Copy it by using CTRL+C and CTRL+V two times. The hide two 
planes:



Now select the actually visual object again and change to the Edit Mode. You will see something 
like a catch surrounding the tube-like structure. If you select now one point and move it, you will 
see that the shape smoothly changes.

However, you can undo this first (e.g. by pressing CTRL+Z). But you still see the grid-like structure
on the surface of the tube. Select the whole model by pressing A and then change the shading like 
this (on the Shading/Uvs tab):



Looks quite good now! For the future, if the surface has a strange look with strange shading, you 
can try to press here “Normales → Recalculate”.

However, you are now only able to change the outer points of the tube. If you want to make changes
more in detail, just do the following: 

Select all by pressing A, then press W and select “Subdivide”. 

Now you are able to make quite granular changes like this:



But before we start this manual modeling process, let us look at some other modifiers.

We have used the Subdivision Surface modifier. Now, we want to use two other modifier classes, to 
create dynamically a wave-like, irregular surface structure.

Select the object in object mode and add the modifier “Wave”. Then, choose these settings:

All settings can be changed by using this window, except the “Start Position Object”. Before we can
change this, we have to create the empty object by using:



The “Empty” Object is used to define the center of the Wave effect. This object 
is abstract, it will not be rendered. After generating this object, you have to 
choose it in the Wave modifier window as the “Start Position
Object”. Select the newly created Empty object and move it
to the center of your cell component object:

A wave-like structure appears.

We learnt already how to copy objects (with CTRL+C/V),
but now we also want to copy effects. Just press the copy
button in the Wave modifier dialog. 

In this copied Wave modifier, you only
have to change this option:

From the top, the object should look like this now:

You have two waves running on the surface of the cell component. If you move now the time 
marker in the time line:

You will see that the effect changes. In this tutorial, we are not interested in animations! But: we are
interested in generating a nice surface. So you can use now the time slider to find a good 
combination of the different wave effects.

However, we want to examine another modifier. Let us still use the first time step. Now, add the 



“Simple Deform” modifier and change the settings like this:

Now your structure should look like this:

So we have some irregular waves now. By the way, you can always test different combinations of 
the modifiers by deactivating the modifier by clicking on the eye:

Optionally, you might want to add more Wave modifiers to gradually distort the surface of the cell 
component, e.g. with two additional ones:



By changing now the time slider, you can change the structure, or by moving the Empty object to 
different positions nearby the cell component.

Blender: Add a Material to the Cell Component

Before we start to export our object, first, let us add a material. Otherwise, the object will be 
exported just white and the 3D structure will be hardly recognizable.

Now, press the “New” button and change the material like this:



1. Add a diffuse color:
the standard color of the object,

2. Add a specular color:
the color reflected at the bright spots where 
light hits the surface of the cell component,

3. Activate the transparency, and

4. Set the level of the transparency:
alpha=0 → invisible,
alpha=1 → fully visible.

Now, our material is finished.

Blender: Export VRML97/2.0 for the CellExplorer

Now, we have created our cell model and assigned a material. To use it with the CellExplorer, it has 
to be exported to VRML2 format.

For this purpose, you have to first import and activate the VRML2 extension. In the already 
mentioned zip file mentioned above, there is the file: vrml_export_266.py. To get the full support of 
all functions described here, download the file vrml_export_270.zip from

http://www.cellmicrocosmos.org/Cmforum/viewtopic.php?f=21&t=750

and extract it to your file system. Then, import it to Blender. First, open the “File” → “User 
Preferences”, then, 1. change to the section “Addons”, 2. click “Install from File ...” and select the 
previously extracted vrml_export_270.py, then, 3. search for “vrml” in the search box and finally, 4.
activate the imported plugin. And 5., it is a good idea to press “Save User Settings”. Otherwise, you 
will have to repeat this whole process again the next time you start blender again.

http://www.cellmicrocosmos.org/Cmforum/viewtopic.php?f=21&t=750


Now, the VRML2 exporter is activated. Let us come back to our Blender cell component model:

Make sure, it is selected, because this VRML exporter exports only the actually selected shapes.

Go now to the menu and select “File” → “Export” → “Export to VRML (.wrl)” and find the 
following menu on the bottom left side:



This nice plugin originally written by Sebastian Lieberknecht supports the following functions 
(import functions are written in italic):

• xyz precision: the number of digits behind the coordinates' comma, so here: XXX.XXXX

• uv precision: the number of digits behind the uv coordinates' comma, so here: XXX.XXXX

• cease angle (rad): the cease angle which is relevant for the normal generation. This number
must be larger than 0 if normals should be generated! Set e.g. the value to 0.5 and the 3D 
meshes will appear later smooth in the CellExplorer.

• global scale:  Change the global scale number for the whole VRML file. This number is 
interpret by many VRML viewers. However, the CellExplorer ignores this values.

• Export animation: if you want to export an animation, you can do this here. The 
CellExplorer ignores this value.

• key precision: relevant only for animations. How many digits the key should use.

• Loop animation: restart the animations

• coordinate rescale: rescale all 3D shapes by using this number [version 2.70 only]
use factor 1000 to export to the CellExplorer

Right click on the term “Cell membrane 1” in the CellEditor window in the CellExplorer and select 
then “Load Model: cellmembrane.wrl” and select then the newly exported VRML file.



This image here shows the newly exported membrane in the CellExplorer:

An important aspect of the export from Blender to CellExplorer is that the origin of the exported 
shape(s) is in the center of the shape. This is especially important for the node placing algorithms in
the CellExplorer, because they start the distribution process based on this center point. It is simple 
to correct the center point:

Click on “Set Origin” and set it to “Origin to Geometry”. Then, 
export again and reload the model by pressing “Reload model” on
the pop up.

Finally, some words about extended cell components. Many cell 
components require the use of multiple layers. E.g., for the 
mitochondrion, 5 layers are needed:

0. matrix

1. inner membrane

2. intermembrane space

3. outer membrane

4. cloud 

Therefore, 5 layers have to be modeled in Blender. Before the model will be exported, it should 
look like this in the Outliner:



The use of numbering is a simple way to define the ordering. Obviously, we are starting from the 
internal membrane #0, the one, which is closest to the origin, and approaching then step by step to 
the outermost layer, #4. This ordering is required by the CellExplorer for the identifiction of the 
different shapes.

Now, make sure that all 5 layers are selected in Blender (you can also select them with 
SHIFT+LMB in the Outliner) and select again the VRML export function. After the export you will 
see that all layers are ordered as you previously defined it in Blender. This works only with plugin 
version 2.70!

This is, how a simple mitochondrion model is shown in the CellExplorer after export with a rescale 
factor of 100:

The alpha value of the transparency of the matrix (layer #0) and the cloud (layer #4) is set to zero.



Blender: Import a Cell Model from the CellExplorer

The following chapter will probably be not relevant for the CmCM project SS2014. But who is 
interested in this topic, here it is described anyway:

If you want to export a model from the CellExplorer to be used in Blender, export a cell model to a 

VRML file by clicking  and save the file.

Now, we want to import the exported VRML file to Blender. For this purpose, make sure that you 
have substituted the folder io_scene_x3d in the Blender\2.67\scripts folder with the one downloaded
from the forum website. This version support the import of text from VRML to Blender.

Now, start Blender. Go to 

File → User Preferences

and make sure that the Web 3D X3D/VRML2 exporter/importer is activated here:

Note: this plugin supports only the import of VRML files. If you want to export VRML files, use 
the file “vrml_export_266.py”, activate it just like the importer and find it in the Files → Export 
dialog. This exporter can also be used to prepare shapes for cell components for the CellExplorer.

Now, import the .wrl file by using:



After the file is important, you will see something like this:

Obviously, the 3D model is much too huge. 

Select the whole model with A and then use now a combination of scaling (with S) and grabbing 
(with G) to decrease the size and to change the position of the cell model. Combine these two 
modes with restricting the movement to a single axis, e.g. by pressing Z afterwards. Always make 
sure that the cell model does not disappear from the view port and move it towards the center of the 
membrane by looking from the top or from the side. A good trick to take the line into account which
appears during pressing S. This line indicates the direction and the position of the rpugh center of all
shapes.

In the end, the cell model should be located in the center:

You know how to handle this model from the previous tutorials. One last hint should be given. If 
you look to the Outliner, you will see a lot of different shapes. The problem is now that it is not easy
to identify the correct cell component in the Outliner. Just select now the visible cell components 
and give them names. But how to do this?



Just change to “Selected” mode in the Outliner and click the cell membrane and change the name of
the shape with a name like “ShapeIndexedFaceSet” to “Cell Membrane”: 

Deactivate the eye symbol and hide the cell membrane. Select the mitochondrion component and 
change then its name.

Now, you can filter objects in the Outliner. Go back to “All Scenes” and use the search field to 
search for a cell component name.
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