This forum is aimed towards anybody who is working with the the MembraneEditor. Installation instructions are found here. Any questions, remarks or critics are welcome. Also this is a chance to get in contact with other users.
Post Reply
User avatar
bjoern
Site Admin
Posts: 210
Joined: 20.03.2006, 15:01
Contact:

Install the MembraneEditor on Linux

Post by bjoern » 06.07.2010, 16:14

With Linux there may be a small problem if you are using not the native Sun Java libraries. The Open Source libraries bundled e.g. with Ubuntu 10 provide only a poor version for Webstart. So please install Sun Java 6 first, before you install the MembraneEditor:

http://Cm2.CELLmicrocosmos.org

User avatar
bjoern
Site Admin
Posts: 210
Joined: 20.03.2006, 15:01
Contact:

Install Problems on Ubuntu

Post by bjoern » 12.11.2011, 14:32

WebStart Installation Problems on Ubuntu

On Ubuntu 10.04 LTS, the installation is normally no problem. But sadly, normally there is a small drawback. But it can be fixed very simple.

So if your desktop is looking like this after the WebStart installation
Screenshot_CmME_Ubuntu1.png
State of Desktop after WebStart installation of CmME on Linux 10.04 LTS
Screenshot_CmME_Ubuntu1.png (614.08 KiB) Viewed 18052 times
and you click on this strange icon (with a name similar like "jws_app_shortcut_1321106907286.desktop"), the following message appears:
Screenshot_CmME_Ubuntu2.png
Message appearing when trying to start CmME on Linux 10.04 LTS by clicking on the icon
Screenshot_CmME_Ubuntu2.png (15.99 KiB) Viewed 18052 times
There are now two possibilities: You start the CmME each time by clicking on the downloaded startCm2.jnlp file. You will find this for example in the Download section of your browser.

But there is a better solution, just do the following:

Now you do just the following. Make a right click on this strange icon and choose Properties. Now proceed to the tab Permissions.
Screenshot_CmME_Ubuntu3.png
The properties of the CmME desktop icon on Linux 10.04 LTS after selecting "Allow executing file as program"
Screenshot_CmME_Ubuntu3.png (41.93 KiB) Viewed 18052 times
There you will find a check box entitled "Allow executing files as program".

Click on Close and you are finished. Your desktop should look like this now:
Screenshot_CmME_Ubuntu4.png
State of Desktop after doing the icon fix
Screenshot_CmME_Ubuntu4.png (611.08 KiB) Viewed 18052 times
This icon should be executable now.

User avatar
bjoern
Site Admin
Posts: 210
Joined: 20.03.2006, 15:01
Contact:

Re: Install the MembraneEditor on Linux

Post by bjoern » 16.11.2011, 18:45

JAVA Installation Problems on Ubuntu

On Ubuntu 10.04 LTS, we are working with Eclipse to run CmME from source.

If you have Java 6 or 7 installed on your system together with Eclipse (also older version of Eclipse run with CmME), there is normally only one small problem: Java3D.

And this problem is fixed very fast:

Goto the "Synaptic Package Manager". Search for:

java3d
Screenshot-Synaptic Package Manager .png
Java3D in Synaptic Package Manager
Screenshot-Synaptic Package Manager .png (69.58 KiB) Viewed 18049 times
Install

libjava3d-jni

It must be version 1.5.X, but version 1.5.2 is recommended.

After it is installed, go to Eclipse. Right click on the Cm2_2 project in your Package window and select properties. Goto the Java Build Path and the tab "Libraries". Edit now the "native library location" of your JRE System Library and enter

/usr/lib/jni
Screenshot-Properties for Cm2_2.png
Project Properties in Eclipse with Java3D jni added
Screenshot-Properties for Cm2_2.png (128.88 KiB) Viewed 18049 times
Problem solved.

Just start now the Start,java file as you are used to. For additional settings, please refer to the README.txt in the project folder.

Post Reply